Skip to main content

EtherChannel Cisco

El Port-Channel (o EtherChannel) consiste en agregar varios enlaces físicos en un único interface lógico. Esto consigue dentro del mismo switch duplicar la capacidad del Interface, o bien si hay dos switches conectados entre sí en modo trunk, permite disponer de redundancia entre ambos. Esto está especificado en estándar IEEE 802.1Q

Para ello necesitamos que esté soportado.

Ejemplos:

Cisco Router 7200 puertos fa3/0 y fa4/0
Cisco7200(config)# interface fa3/0
Cisco7200(config-if)# channel-group 1

FastEthernet3/0 added as member-1 to port-channel1
 Cisco7200(config-if)# exit
Cisco7200(config)#
00:25:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up
Cisco7200(config)# interface fa4/0
Cisco7200(config-if)# channel-group 1

FastEthernet4/0 added as member-2 to port-channel1
 Cisco7200(config-if)# exit
Cisco Catalyst puertos fa0/2 y fa0/3 
Cat2950(config)# interface fa0/2
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit
Cat2950(config)#
00:25:38: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:25:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up
Cat2950(config)# interface fa0/3
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit
Cisco Nexus
switch# configure terminal 
switch(config)#
switch(config)# feature lacp
switch(config)# interface port-channel 1
switch(config-if)# description almacenamiento
switch(config-if)# no shutdown
switch(config)# interface ethernet 1/4
switch(config-if)# channel-group 1
switch# show interface port channel 1

Portchannel LACP Layer 2

switch# configure terminal
switch (config)# feature lacp
switch (config)# interface port-channel 5 
switch (config-if)# interface ethernet 1/4 
switch(config-if)# switchport 
switch(config-if)# channel-group 5 mode active 
switch(config-if)# lacp port priority 40000
switch(config-if)# interface ethernet 1/7 
switch(config-if)# switchport 
switch(config-if)# channel-group 5 mode

Portchannel LACP Layer 3

switch# configure terminal
switch (config)# interface ethernet 1/5
switch(config-if)# no switchport 
switch(config-if)# no ip address 
switch(config-if)# channel-group 6 mode active 
switch (config)# interface ethernet 2/5 
switch(config-if)# no switchport 
switch(config-if)# no ip address 
switch(config-if)# channel-group 6 mode active 
switch (config)# interface port-channel 6 
switch(config-if)# ip address 10.30.2.1/24